For the best experience with Teamdresser use Firefox 18.0 or newer. Download the latest version of Firefox here.